OpenMediaVault 4

OpenMediaVault 4 è la nuova versione del software che puoi utilizzare per realizzare il tuo NAS, un server DNLA e un TimeMachine server

OpenMediaVault 4 omv web interface

Hai probabilmente già letto le fasi di installazione della versione 3.0 in questo articolo di qualche mese fa.

Oltre ad installare la nuova versione del prodotto in questo articolo installerai OpenMediaVault 4 su una raspbian stretch, puoi seguire l’installazione con etcher.

Installazione manuale della OpenMediaVault 4

L’installazione manuale del software OpenMediaVault 4 è descritta in modo dettagliato nella documentazione ufficiale che non è semplice da trovare partendo dal download:

OpenMediaVault 4 download page

ma puoi seguire il link che ho messo prima dell’immagine e che riporta le istruzioni come di seguito:

OpenMediaVault 4 Raspberry Pi 3 Debian 9 istruction

in cui ti indica di aggiungere il repository:

/etc/apt/sources.list.d/openmediavault.list

copiando e incollando le righe del primo riquadro.

Il risultato dovrebbe essere simile al seguente:

OpenMediaVault 4 install apt source

Ora è necessario eseguire l’export delle variabili che occorrono all’installazione:

OpenMediaVault 4 exports variables

ed eseguire un:

apt-get update

come mostrato in figura:

OpenMediaVault 4 apt get update success

Nel caso dovessi incontrare un errore relativo alla mancanza di autorizzazioni sufficienti per verificare la fonte del repository appena aggiunto puoi seguire la procedura di autorizzazione seguente:

OpenMediaVault 4 allow keyring

al termine della quale è bene che tu esegua nuovamente l’apt-get update.

Installa OpenMediaVault 4

Passa all’installazione vera e propria di OpenMediaVault 4 eseguendo il comando:

apt-get --yes --auto-remove --show-upgraded \
    --allow-downgrades --allow-change-held-packages \
    --no-install-recommends \
    --option Dpkg::Options::="--force-confdef" \
    --option DPkg::Options::="--force-confold" \
    install postfix openmediavault

durante la quale vedrai una schermata simile alla seguente e se non ci sono errori OpenMediaVault 4 è installato:

OpenMediaVault 4 install omv

ed al termine potrai provare ad eseguire lo start di OMV con:

omv-initsystem

e probabilmente otterrai un errore similare:

OpenMediaVault 4 omv init system

che ti avvisa della mancanza di alcuni software necessari a procedere con l’avvio di OpenMediaVault 4.

Installa i pacchetti mancanti con il consueto apt-get install:

OpenMediaVault 4 install resolvconf pkg

ed al termine potrai rieseguire il comando di start:

OpenMediaVault 4 omv init system success

Verifica dell’installazione di OpenMediaVault 4

Puoi verificare l’installazione appena eseguita controllando i processi attivi:

OpenMediaVault 4 omv check the processes

e quindi che ci sia in ascolto la porta 80 sul sistema:

OpenMediaVault 4 omv check web interface port

e che tale porta accetti connessioni da qualsiasi indirizzo, potrai limitare l’accesso al NAS con le regole iptables ( firewall linux ) se necessario.

Collegati alla porta 80, esegui il login e dovresti vedere tra le caratteristiche del NAS la seguente schermata informativa:

OpenMediaVault 4 omv web interface

Nei prossimi articoli installerai le nuove componenti extra per avere molti plugin e add-on a disposizione.

Prima di inserire un commento, per favore, leggi il regolamento

Permanent link to this article: http://www.mauroalfieri.it/elettronica/openmediavault-4.html

4 comments

Skip to comment form

    • Sergio on 21 Aprile 2018 at 17:46
    • Reply

    Grazie! Uno dei pochi in italia che tratta di OMV. Complimenti! Guide molto utili, per chi come me, si approccia per la prima volta! Grazie ancora!

    1. Grazie Sergio,
      ne pubblicherò delle altre nei prossimi giorni

    • Marco Q. on 28 Dicembre 2018 at 18:48
    • Reply

    Ciao Mauro
    ho installato omv sul RB. Non riesco ad accedervi via web (digitando nel browser del pc connesso alla stessa rete domestica l’indirizzo ip del RB) da connessione non riuscita. Ho il dubbio che ci siano problemi sulla porta 80. Ho verificato l’installazione corretta con il comando da te fornito “ps -ef |grep omv” ed è ok. Quando inserisco il comando “netstat -an |grep :80” il terminale non fornisce alcun risultato!

    1. Ciao Marco,
      il fatto che il comando “netstat -an |grep :80” non dia risultato è significativo della mancata apertura della porta 80, quella di default per il browser, che implica l’impossibilità di connettersi via browser.
      Prova a verificare dopo un riavvio della RaspBerry Pi se la porta viene resa disponibile, in caso contrario dovrai indagare nei log per comprendere cosa non stia funzionando.

Lascia un commento

Your email address will not be published.

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.